I have been working on something big for ~2-3 months and I'm at my final stages of completion, yet I have come upon 2 issues:
I. The hull screams "Battle ready" but the bridge screams "acoustic speedboat" (My first build with a bridge meant for disposable space men)

II. I can get it off the ground but is just as maneuverable as a Roman-Era brick with with half a broken fanblade for wings. Hell, i even tried using 2 groups of engines that face opposite directions when pitch is manipulated, the ungodly amount of salvaged gyroscopes on it would make the CEO of a quadcopter company have an aneurism at just hearing it. I might just scrap the whole thing altogether and work on another abomination that most likely will never work.

Tags
Question

4 Comments

  • Log in to leave a comment
  • Profile image
    40.1k Gozinya

    Post this thing!!! I can’t promise I can fix it but if you @ me I’ll give it a shot. I like your stuff so I’m willing to help if I can.

    1.6 years ago
  • Profile image
    5,694 SelectAKey

    this happens to me all the time. i accidentally forget to save often enough and then when i do its an overwrite of a good save with a bad one and the craft is then useless to me. thankfully i try to keep my part count low and mirror everything so getting back to something working doesnt take long.

    +1 1.6 years ago
  • Profile image

    @Dogfish5550 i might try, though I strongly believe that the chances of getting help are slim.

    +1 1.6 years ago
  • Profile image
    3,006 CASXA

    Maybe upload it and see if someone can help with it?

    +1 1.6 years ago

No Upvotes

Log in in to upvote this post.