Hi all,

I made a video to describe the issue:
https://www.youtube.com/watch?v=TafihVrvdLE

I'm struggling with an issue already for a while: when a new craft docks to my space station, other attached/docked crafts undock straight after. Some excessive force is suddenly applied, forcing other crafts to undock. I've tried to power off the other command pods as well and I dock without automatic targetting set. FYI: engines are idle, RCS is doing nothing when docking.

This seems a bit like a bug to me. Is this something known, or am I doing something wrong here?

Sandbox: https://www.simplerockets.com/s/SSr7r5/Docking-undocks-other-craft

Tags
Question

19 Comments

  • Log in to leave a comment
  • Profile image
    19 AlexNL

    The sandbox posted in this issue related to this post is still legitimate for the issue described in this post and the sandbox related to the bug I posted is also valid.

    Both are separate issues, but undocking is involved in both. I really hope the developers can help out in the (un)docking process, also in making it in such a way that docking is more realistic (with something to aim for the docking port).

    I really love the game, and although it has some flaws and I had been at the point several times to abandon it and uninstall it (the only other game I did that ever with was some bus simulator game) I refrained from doing so and gave it another shot later. Simplerockets keeps appealing to me and I just really hope that the devs can help out fixing these incredibly annoying issues.

    +1 2.0 years ago
  • Profile image
    5,694 SelectAKey

    @AlexNL awesome as long as you report those bugs and keep testing . if need be i can always respost your sandbox cause i have it saved but you might have and updated one?

    2.0 years ago
  • Profile image
    19 AlexNL

    No worries. In the mean time, I changed the space station and now undocking when docking does not happen anymore. A new bug popped up however btw.: approaching the station within 1km undocks a craft from the space station.

    So, something in Simple Rockets is definitely not right with this. I have reported this as an official bug, with a sandbox https://www.simplerockets.com/s/Xsv4OQ/ . If anyone would like to try it as well, feel free. Don't forget the reproduction path in the sandbox'es description.

    +2 2.0 years ago
  • Profile image
    5,694 SelectAKey

    @AlexNL sorry ive been in a bit of a slump lately havent done anything

    2.0 years ago
  • Profile image
    19 AlexNL

    @SelectAKey Any luck? :)

    2.0 years ago
  • Profile image
    19 AlexNL

    @SelectAKey Nice, appreciated!

    2.0 years ago
  • Profile image
    5,694 SelectAKey

    @AlexNL downloading now

    +1 2.0 years ago
  • Profile image
    19 AlexNL

    No I didn't initially. :) But after you asked for it, I uploaded it right away. Have you tried it?

    2.0 years ago
  • Profile image
    5,694 SelectAKey

    @AlexNL so no you didnt upload it

    2.0 years ago
  • Profile image
    19 AlexNL

    Here's the sandbox:
    https://www.simplerockets.com/s/SSr7r5/Docking-undocks-other-craft

    It's 'Fueler 5' heading for DSI Base Station. It would be really cool if the cause to the issue is known.

    2.0 years ago
  • Profile image
    5,694 SelectAKey

    did you post the sandbox by any chance?

    2.0 years ago
  • Profile image
    5,694 SelectAKey

    @AlexNL can always launch everything into orbit all as one piece. but that might prove to be rather frustrating

    2.0 years ago
  • Profile image
    19 AlexNL

    Yes, so that's why I am also curious about the solution as building a space station is now practically impossible.

    2.0 years ago
  • Profile image
    5,694 SelectAKey

    @AlexNL very curious

    2.0 years ago
  • Profile image
    19 AlexNL

    All docking ports where powered. I only unpowered all other command pods as I tried to get a solution for this.

    I'd really like to know what's causing the heavy force on the other crafts when I dock. The craft came in slowly, docked 'itself' (no force applied except from the pulling force of the port itself).

    2.0 years ago
  • Profile image
    5,694 SelectAKey

    @AlexNL without downloading did you make the docking ports active or innert?

    2.0 years ago
  • Profile image
    19 AlexNL

    @SelectAKey If you mean me, no. :( I really want to know what's going on here.

    2.0 years ago
  • Profile image
    5,694 SelectAKey

    your kidding right?

    2.0 years ago
  • Profile image
    7,232 Insanity

    Its the KRAKEN!

    2.0 years ago

No Upvotes

Log in in to upvote this post.